Office 365 Incident EX255432
Incident Report for Affordable IT
Resolved
This incident has been resolved.
Posted May 11, 2021 - 10:10 BST
Update
This issue has now been resolved by Microsoft. We will do one final sweep of all quarantined items and release any that shouldn't be in there!
Posted May 11, 2021 - 10:10 BST
Update
Just an evening update - this is still an ongoing issue with Microsoft. We are continuing to monitor the issue and have been releasing emails that we're incorrectly blocked to peoples mailboxes throughout the day. If the issue is still there in the morning we will continue to do the same tomorrow.
Again - if you send in a support ticket and we don't receive it then please ring us on 02380 000770 as we use O365 as well for our emails :)
Have a good evening!
Posted May 10, 2021 - 22:09 BST
Update
Should have also mentioned that this affects our email ticketing system and our main @aff-it.co.uk emails. We are monitoring our own quarantine for mis-caught emails but if we don't reply to you then please ring us on 02380 000770.
Posted May 10, 2021 - 13:25 BST
Identified
**IF YOU ARE MISSING ANY EMAILS PLEASE GET IN TOUCH WITH US AND WE CAN RELEASE THEM TO YOU**
Ongoing issue with Microsoft Office:
Title: Some users are seeing that legitimate email is being quarantined within the Exchange Online service
User Impact: Users are seeing that legitimate email is being quarantined within the Exchange Online service.
Current status: We've identified that this issue is affecting a wider region and are working to delist the legitimate URLs from our anti-spam detection, to resolve the issue.
Posted May 10, 2021 - 13:22 BST
This incident affected: Hosted Email Services (Office 365) and AFF-IT Company Systems (Emails, Ticketing System).