Office 365 Email Processing Delays
Incident Report for Affordable IT
Resolved
We have been advised that this issue has now been resolved. Please let us know if you are still experiencing delays in sending and receiving emails from your Office 365 account!
Posted Jun 21, 2022 - 13:52 BST
Identified
We are currently aware of an issue with a delay in incoming and outgoing email processing with Office 365. As far as we are aware this is a widespread issue and affects a lot of end users. We have raised this with Office 365 support and are awaiting to hear back from them.

We are also aware of the irony of a status page that sends emails when there is an email processing issue. Please feel free to bookmark https://status.aff-it.co.uk for any future updates, issues or maintenance notices!
Posted Jun 21, 2022 - 11:37 BST
This incident affected: Hosted Email Services (Office 365).