Office 365 Issue with Sending and Receiving Emails
Incident Report for Affordable IT
Resolved
This issue has now been resolved by Microsoft
Posted Aug 01, 2022 - 09:46 BST
Identified
Office 365 are currently having issues with sending and receiving emails. Below is the information we currently have from Microsoft:

"Some users are intermittently unable to send or open email via the Outlook desktop client and Outlook on the web."

In outlook you may also see a message in the bottom right hand corner of "This folder was last updated on xxx"

Microsoft are currently working on a fix for this and we will update this page when we have any more information from them
Posted Jul 29, 2022 - 11:23 BST
This incident affected: Hosted Email Services (Office 365).